question

$$anonymous$$ avatar image
0 Likes"
$$anonymous$$ asked ·

Adding Tracking Numbers with CompleteSaleRequest getting Success but Not Adding Trakcing Numbers

hi .. i am trying to add Tracking numbers with ebay API. Once i run this code i can see Success ( even in With ebay testing tool under developers website ). but i am not able to see Tracking numbers : Here is code i am Using : my_ebay_eBayAuthToken 110154684599 27387395001 Half true Item Shipped We are very Glad to have you 1030385557492892794611 USPSGround Result : 2015-01-05T16:58:37.217Z Success 893 E893_CORE_API_17097905_R1 But i am not able to see tracking numbers in Order.
trading apiPHPebay apixmltracking-numbers
· 2
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

We are seeing the same thing. Did you ever figure out a resolution?
0 Likes 0 · ·
I was not able to reproduce and didn't get the information I had asked for, so no resolution that I know of.
0 Likes 0 · ·
coopaupau avatar image
1 Like"
coopaupau answered ·
I need to do some more tests, but for me it seems to ignore the tracking number as well. It ignores both of these: ShipmentTrackingNumber ShippingCarrierUsed The order gets marked as "despatched" within eBay, but the method and tracking number don't get updated/added. Edit - in my software it was working before, so this has broken recently.
· Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

patekaja_0 avatar image
0 Likes"
patekaja_0 answered ·
How to add Tracking Information using PHP with XML???????
· Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

twocrazycacti avatar image
0 Likes"
twocrazycacti answered ·
Has this still not been resolved?!?! I'm having the exact same problem.
· 1 · Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Never mind, I just realized I needed to up the version number I was using to 635.
0 Likes 0 · ·
$$anonymous$$ avatar image
0 Likes"
$$anonymous$$ answered ·
hi @neatoscan But ShippingCarrierUsed is optional in API documentation..
· Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

neatoscan avatar image
0 Likes"
neatoscan answered ·
@singssisande - I've purchased support and opened quite a few cases. They have always been very helpful and they actually very rarely deduct hours for our cases. I've opened a case. In my case, we are having issues in production not just the sandbox environment. My guess is that it has something to do with the specific values we are setting for ShippingCarrierUsed and they have recently added some checks on this value to make sure it conforms.
· 2 · Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

hi @neatoscan But ShippingCarrierUsed is optional in API documentation..
0 Likes 0 · ·
ShippingCarrierUsed They haven't edited the documentation, and I'm not getting any API errors. Would be a pretty bad bug if they've done that because it's failing silently (orders are getting marked as despatched, but tracking number and method are not being set). Also ShippingCarrierCodeType appears to be missing loads of values, unless the documentation hasn't been updated.
0 Likes 0 · ·
$$anonymous$$ avatar image
0 Likes"
$$anonymous$$ answered ·
Open a ticket means pay near about 300$ for 4 hours.. there's no support for developers on ebay.. this is too much...
· 2 · Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

You don't have to pay for 4 hours. You can purchase just one hour and as a matter fact we don't charge for bugs. So essentially you would still have that hour for future use. You can also give me your developerID and I can open up the support this one time since this is a bug.
0 Likes 0 · ·
I can understand why you charge for support because 99.9% if the time it won't be a real bug, but I'm not paying to get this one checked either. I'll do some more tests myself just to make sure something hasn't gone wrong in my software (although this part of my code hasn't been edited for about 18 months). I reported another issue on here which was confirmed as bug, which is on a similar topic. When you reply to messages through the API, they don't get marked as "replied" within eBay. So maybe it's a similar bug - some action in the API not resulting in an update within the eBay interface.
0 Likes 0 · ·
coopaupau avatar image
0 Likes"
coopaupau answered ·
@jourbandts In the reply on the other thread you said this: "On another note, the ShippingCarrierUsed is an invalid value, that could be causing the issue." Previously this value could be set to anything. For example, one of my clients uses Interlink, which is not an option in the enumeration. I would send "Interlink" and this would go through okay. Has this been tightened up to only accept" ShippingServiceDetailsType" values? EDIT: my issue is not on the Sandbox, it's on the production servers. It was working fine in my software but stopped working a while ago. EDIT 2: in the documentation it still says this: "Name of the shipping carrier used to ship the item. Although this value can be any value, since it is not checked by eBay, commonly used shipping carriers can be found by calling GeteBayDetails". So I assume that would not be the cause.
· Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

jourbandts avatar image
0 Likes"
jourbandts answered ·
As I mentioned this is most likely an issue with our sandbox. Since there seems to be so many of you with an issue I would strongly suggest opening a support ticket so we can open a bug and get the issue fixed, http://developer.ebay.com/support/developersupport/
· Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

$$anonymous$$ avatar image
0 Likes"
$$anonymous$$ answered ·
thanks for comment @coopaupau even i am not able to see any dispatched or shipped mark... No Idea what's going on : i have one more post here but still pending : https://forums.developer.ebay.com/questions/9758/ebay-api-adding-tracking-numbers-error-number-1000.html if you find anything please comment
· Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

$$anonymous$$ avatar image
0 Likes"
$$anonymous$$ answered ·
Someone ask me : May be this is issue : ( because i am using ebay sandbox ) Half but i already remove this tag.. but still issue is same..
· Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.