question

shkaraoke avatar image
0 Likes"
shkaraoke asked

Self hosted images not being copied to EPS

Until recently I have been listing items fine with an external picture URL in PictureDetails.PictureURL and this picture has been copied to EPS without any problems. This week when listing I noticed all new listings resulted in a "Gallery picture issue" email being sent. After some investigating it appears images are no longer being copied to EPS. I have tried to copy them directly using the UploadSiteHostedPictures call which results in an error code 21916545, "Data retrieval of the file specified by ExternalPictureURL failed". We have had no problems with this before and nothing has changed at our end, is there a problem with the picture uploader copying from external URLs at the moment?
problem with copying pictures from external urls
10 |600

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

·
shulmani_developer.support avatar image
0 Likes"
shulmani_developer.support answered
Hi, Are you sure the server where you host the pictures is accessible? Usually you would get the errors that you have mentioned when eBay tries to access the server where the pictures are hosted, but cannot as the server maybe unreachable. Cheers!!!
· 3
10 |600

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Thanks for the reply, the server is definitely OK - it is the same one used to host our website and the images on it. When viewing the newly created listings, the main picture is showing OK but is hotlinked from our website (the same URL that is failing with UploadSiteHostedPictures) instead of being copied to EPS and being loaded from there as it always has done before. As they haven't been copied over to EPS the gallery image is obviously not showing in the search result pages
0 Likes 0 ·
Can you share the recent failed response xml for the UploadSiteHostedPictures? We can check our logs and see what the issue is. It will also be great if you can provide us the itemID. Cheers!!!1
0 Likes 0 ·
Hi shrut_h Thanks for getting back to me, I didn't keep a copy of the XML unfortunately and have now re-written the function to download the image from our website and upload to EPS as a MIME attachment using UploadSiteHostedPictures which works for now. I'm not sure what the problem was but it seems EPS wasn't able to connect to our website even though the site was and is still accessible through a browser, I tried the same function using a random image from another site and it worked fine.
0 Likes 0 ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.