question

palambi_de avatar image
0 Likes"
palambi_de asked ·

GetMyMessages plain text (content-tag) not returned

https://go.developer.ebay.com/developers/community/blogs/ebay_staff/getmymessages-now-returns-message-body-text-format This link says that GetMyMessages calls return (plain text, not HTML), but it's not working. Any ideas?
apigetmymessagesmessagemissing-fields-api
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

shulmani_developer.support avatar image
1 Like"
shulmani_developer.support answered ·
Hi, I did try this API Call and see the plain text returned in the response in the tag : http://developer.ebay.com/DevZone/XML/docs/Reference/ebay/GetMyMessages.html#Response.Messages.Message.Content. If its not working for you, Can you please give me the sellerID and the messageID? I can take a look at it. Cheers!!!
· 5 · Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Currently it's not possible for me to send messages in sandbox via API or without API (?) Outside of sandbox it works. I will give you a SellerID and messageID as soon as it's possible. I don't know why I don't get the content tag :/ I don't want to code a workaround for the HTML part. I get the output, which is listed here. http://developer.ebay.com/DevZone/XML/docs/Reference/ebay/GetMyMessages.html#samplespecifics
0 Likes 0 · ·
hi, I think messaging is broken in sandbox. I tried in production and it works . But it would be great if you can provide me a messageID and sandbox userid. Cheers!!!
0 Likes 0 · ·
palambi_de avatar image palambi_de shulmani_developer.support ♦♦ ·
Hi, sandbox userid = testuser_lucider5 messageID = 20189790 It's an eBay message. Cheers!
0 Likes 0 · ·
It doesn't even work with buyer messages. I tried both eBay and buyer messages.
0 Likes 0 · ·
Hi, I am sure that it works in production. But since messaging is broken in sandbox, I am assuming that it wont work. I will test a bit and let you know. Cheers!!!
0 Likes 0 · ·
mallee.mel.vic avatar image
0 Likes"
mallee.mel.vic answered ·
@shulmani_developer.support Any further news about plain text in messages? Thanks.
· Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

mallee.mel.vic avatar image
0 Likes"
mallee.mel.vic answered ·
I have this same problem for GetMyMessages call. Is there any solution to get plain text from message? In my test, both Messages.Message.Text and Messages.Message.Content return same thing with HTML tags. Thank for any further help.
· Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

legolomania avatar image
0 Likes"
legolomania answered ·
Has this been fixed yet? As far as I can see it is still returning html instead of plain text?
· Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

yashic_9 avatar image
0 Likes"
yashic_9 answered ·
Hi. Can you help me with the issue. I'm doing getmymessagescall to get all the messages for now, but couldnt get any message except the welcome to ebay message. Can you show me how you implemented, i'm using ebay .net sdk and following the parameters in xml example in the docs, there are no date restrictions, yet its not giving me any messages. I have created 2 seller accounts in ebay and via contact a member link i have sent messages vice versa, will getmymessagescall give me such messages?
· Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

engadgets_au avatar image
0 Likes"
engadgets_au answered ·
It doesn't work in production either! I get all html tags. It doesn't show as plain text even now! PLEASE FIX! I am using Messages.Message.Content. This is ridiculous!
· Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.