question

repka7 avatar image
0 Likes"
repka7 asked

Incorrect Call response

I assume there is a bug somewhere: After making GetMyeBaySelling Call I receive a response without opening tag , and closing tag is ; can'd do anything with that corrupt Response.
bug-notificationbugsbug-fix
· 1
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Tags disappeared: opening - SellerProfiles, closing SellerProfiles/ (slash is in the end instead of front)
0 Likes 0 ·
davidtsadler avatar image
0 Likes"
davidtsadler answered
If you are seeing <SellerProfiles /> in the XML then that is valid and the response is not corrupt. It's shorthand for <SellerProfiles></SellerProfiles> and simply means that the SellerProfiles element has no children.
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

repka7 avatar image
0 Likes"
repka7 answered
Hello David, many thanks for your expertise. The problem is - there should be profiles and there were no changes to the account, especially to the profiles, today except one extra listing...
· 1
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

I'm not sure why it's come back empty. It may be that the item was listed without any policies been applied to it but I'm not 100% sure. You could try a GetItem and see if the business policy profiles are returned with that. Note: you would need to ensure that you set DetailLevel to ReturnAll in GetItem so that the SellerProfiles element will be returned.
0 Likes 0 ·
shulmani_developer.support avatar image
0 Likes"
shulmani_developer.support answered
Hi, Can you please provide the request that you are using ( without the token ) and also the seller id and the SiteID? We can check and see what the issue is. Cheers!!!!
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

repka7 avatar image
0 Likes"
repka7 answered
Dear Shrut, thanks you for your help. It was my fault. Can you tell me how to include buyer's address in GetMyeBaySelling call? Sincerely,Hello Shrut, It was my fault. thank you for your help Can you tell me how to include buyer's address in GetMyeBaySelling Call Sincerely,
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

shulmani_developer.support avatar image
0 Likes"
shulmani_developer.support answered
Hi, If you see the documentation of GetMyeBaySelling, it returns only the buyer's Shipping address postal code : http://developer.ebay.com/DevZone/XML/docs/Reference/eBay/GetMyeBaySelling.html#Response.SoldList.OrderTransactionArray.OrderTransaction.Order.TransactionArray.Transaction.Buyer.BuyerInfo.ShippingAddress.PostalCode . If you want the Shipping Address which might not be the buyer's registration address, you can use the GetOrders API Call: http://developer.ebay.com/DevZone/XML/docs/Reference/ebay/GetOrders.html#Response.OrderArray.Order.ShippingAddress If you want to get the buyers registration address, you can use the GetUser API Call : http://developer.ebay.com/DevZone/XML/docs/Reference/ebay/GetUser.html#Response.User.RegistrationAddress, provided you have a transaction relationship with the buyer. Hope this helps. Cheers!!!
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.