question

minzliu avatar image
0 Likes"
minzliu asked ·

ShippingCarrierUsed for Australian site

I'm trying to set tracking numbers for ebay orders via the api. Reading the doco, i should make a call to completeSale specifying the ShipmentTrackingNumber and ShippingCarrierUsed fields. the doco further says to make a call to GeteBayDetails requesting ShippingServiceDetails for a list of valid values for ShippingCarrierUsed, however when queries on the australian store (both sandbox and prod) this returns nothing. I've been trying the value 'Australia Post' with varied success in sandbox, the api call succeeds, however when users login, the carrier is shown correctly, but the tracking URL defaults to USPS, furthermore querying the order via the api returns the carrier as USPS in production, the api fails with a message saying that the request is invalid, however it did accept the value 'Other' and 'AustraliaPost' but the later prevents the tracking url from working. has anyone done this before? what value do you use?
completesales
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

· Write an Answer
$$anonymous$$ avatar image
0 Likes"
$$anonymous$$ answered ·
Hello minzliu, In order to investigate into this issue we need more details from you. So I would suggest you to create a ticket for this error from [here][1]. Regards [1]: http://developer.ebay.com/support/developersupport/tickets/
· Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.