question

bigchap1420 avatar image
0 Likes"
bigchap1420 asked

errorId 11002 and Invalid Application

Hi there, I'm trying to make my first call (using getSearchKeywordsRecommendation) and am getting a the errorId 11002. It's telling me that I have an "Invalid Application: [My AppID HERE]" - I am using my sandbox key that I previously generated. I may have not set up/unlocked the AppID correctly, as this is the first time I've tried to use it, so it has not been tested previously. Any ideas guys? Thanks!
appid
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

jourbandts avatar image
0 Likes"
jourbandts answered
You need to make sure you are using the correct AppID with the correct environment. My guess is you are using your sandbox AppID but the production endpoint, make sure you are using, http://svcs.sandbox.ebay.com/services/search/FindingService/v1
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

floratrpabl avatar image
0 Likes"
floratrpabl answered
Regards I'm having the same issue, I used some calls before but in this occasion I'm getting an error, what I think is because my App ID comes with an accent (I worked with some App ID for some customers but before but this is the first time I see an accent in the App ID). Is it possible the accent vowel "ó" in my App ID is making mess all? In advance thank you for your help
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

helios825 avatar image
0 Likes"
helios825 answered
That's an interesting quirk - an accent character in the AppID. I wouldn't think UTF-8 is supported there, but maybe it is. I wouldn't be surprised if you're right though, and that's the cause. You could try another AppID for the exact same API call and see if you're getting the issue/error.
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

floratrpabl avatar image
0 Likes"
floratrpabl answered
Yeah, I just got an App ID borrowed and it worked fine... Now I don't know how to connect with this App ID, Any suggestion?
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

helios825 avatar image
1 Like"
helios825 answered
File a tech support ticket. They'll likely either fix it on the backend or issue a replacement keyset/AppID to you or your client.
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

floratrpabl avatar image
0 Likes"
floratrpabl answered
Ok, I will, thank you for your help
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

meghakhamartest avatar image
0 Likes"
meghakhamartest answered
I am facing same problem for SellerProfilesManagementService calling this api Please reply me as soon as possible and my endpoint is I am using production api " https://svcs.ebay.com/services/selling/v1/SellerProfilesManagementService?OPERATION-NAME=getSellerProfiles&SERVICE-NAME=SellerProfilesManagementService&GLOBAL-ID=EBAY-AU&version=1.0.0&RESPONSE-DATA-FORMAT=XML&SECURITY-TOKEN=myToken"
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.