question

hado3671 avatar image
0 Likes"
hado3671 asked

bulkCreateOrReplaceInventoryItem Error 25001,bulkCreateOrReplaceInventoryItem errorId:25001

POST https://api.sandbox.ebay.com/sell/inventory/v1/bulk_create_or_replace_inventory_item
Request ->
{"requests":[{"sku":"REPOHALO","condition":"NEW","conditionDescription":"Bu alan a\u00e7\u0131klama i\u00e7indir","locale":"en_US","availability":{"shipToLocationAvailability":{"availabilityDistributions":[{"fulfillmentTime":{"unit":"DAY","value":"10"},"merchantLocationKey":"Autoooohooo2","quantity":20}],"quantity":5}},"packageWeightAndSize":{"dimensions":{"height":5,"length":5,"unit":"CENTIMETER","with":10},"packageType":"LETTER","weight":{"unit":"KILOGRAM","value":"2"}},"product":{"aspects":{"Brand":["Apple"]},"brand":"Go Pro","description":"Go Pro Description","ean":["ean"],"epid":"epid","imageUrls":["https:\/\/www.pixsy.com\/wp-content\/uploads\/2021\/04\/ben-sweet-2LowviVHZ-E-unsplash-1.jpeg"],"isbn":["isbn"],"mpn":"mpn","subtitle":"sub title alan\u0131","title":"Ba\u015fl\u0131k alan\u0131","upc":["upc"]}}]}

Response ->

{ "responses": [ { "statusCode": 500, "sku": "REPOHALO1", "locale": "en_US", "warnings": [], "errors": [ { "errorId": 25001, "domain": "API_INVENTORY", "subdomain": "Selling", "category": "REQUEST", "message": "A system error has occurred. Internal System Error" } ] } ]}



1- When I submit the request I get an error but when I submit a getInventoryItems request I see the request I created.

2- I can't see the items I created in the Sandbox panel

3- bir hafta önce HTTP 200 OK döndürüyordu ama artık HTTP 500 dönderiyor


where am i doing wrong?

rlogid = t6pitnmsgwj%28ciuoopu0asu%60pkal%3C%3Dosutowoiudvn.mjv%7B3%2Bsfvu7371-17d31ff9ffa-0x25a

,

POST https://api.sandbox.ebay.com/sell/inventory/v1/bulk_create_or_replace_inventory_item
Request ->
{"requests":[{"sku":"REPOHALO","condition":"NEW","conditionDescription":"Bu alan a\u00e7\u0131klama i\u00e7indir","locale":"en_US","availability":{"shipToLocationAvailability":{"availabilityDistributions":[{"fulfillmentTime":{"unit":"DAY","value":"10"},"merchantLocationKey":"Autoooohooo2","quantity":20}],"quantity":5}},"packageWeightAndSize":{"dimensions":{"height":5,"length":5,"unit":"CENTIMETER","with":10},"packageType":"LETTER","weight":{"unit":"KILOGRAM","value":"2"}},"product":{"aspects":{"Brand":["Apple"]},"brand":"Go Pro","description":"Go Pro Description","ean":["ean"],"epid":"epid","imageUrls":["https:\/\/www.pixsy.com\/wp-content\/uploads\/2021\/04\/ben-sweet-2LowviVHZ-E-unsplash-1.jpeg"],"isbn":["isbn"],"mpn":"mpn","subtitle":"sub title alan\u0131","title":"Ba\u015fl\u0131k alan\u0131","upc":["upc"]}}]}

Response ->

{ "responses": [ { "statusCode": 500, "sku": "REPOHALO1", "locale": "en_US", "warnings": [], "errors": [ { "errorId": 25001, "domain": "API_INVENTORY", "subdomain": "Selling", "category": "REQUEST", "message": "A system error has occurred. Internal System Error" } ] } ]}



1- When I submit the request I get an error but when I submit a getInventoryItems request I see the request I created.

2- I can't see the items I created in the Sandbox panel

3- bir hafta önce HTTP 200 OK döndürüyordu ama artık HTTP 500 dönderiyor


where am i doing wrong?

rlogid = t6pitnmsgwj%28ciuoopu0asu%60pkal%3C%3Dosutowoiudvn.mjv%7B3%2Bsfvu7371-17d31ff9ffa-0x25a

inventory item25001error 500 internal server errorhttp 500
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

0 Answers

· Write an Answer

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.