question

bidhelp avatar image
0 Likes"
bidhelp asked

Marketplace Account Deletion 444 ERROR While Sending Test Notification

I have the endpoint correctly set up and verified with the challengeResponse.

While sending a test notification to my endpoint to complete the process I continue getting a 444 error pop up window on the eBay page. The end point should be set up correctly.

" Notification delivery failed with HTTP status code 444 from https://www.mysite.com/api/path Please ensure that the marketplace account deletion notification endpoint is ready to receive notifications. "


Is this an eBay error or is there something I am missing?

It seems like eBay isn't even trying to send me a test notification as no request is showing on my server log.

marketplace account deletion notification endpoint
· 2
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Same problem here. Let me know if you get it fixed. I am getting a 400 error and it appears the the test notification is not even making it to my verified endpoint.
0 Likes 0 ·
bidhelp avatar image bidhelp musical-progressions ·
Hi - did you have any luck getting the notification to hit your endpoint? I am still not receiving any request.
0 Likes 0 ·
swappart avatar image
0 Likes"
swappart answered

If you're using PHP, I have a complete working solution at the link below.

https://forums.developer.ebay.com/questions/43122/working-code-marketplace-account-deletion-notifica.html

· 3
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Thanks for the response. I've taken a look at the code previously. Honestly, not really sure what the issue is. We successfully verified our endpoint with the token response, but it seems like for whatever reason the POST requests being sent by eBay on the test notification are not even hitting the server. (I even set up a blank 204 response to test, nothing hit the server) I wish they showed some additional details as to what exactly the error is, which would help debugging. All the error says is the test notification failed to send, and nothing is hitting my server. :/

0 Likes 0 ·

It may be that your server isn't getting the eBay signature from the headers. I put together an endpoint tester which sends the exact same test message as eBay's server. You can download it from my site as a text file. Put it on your server, rename it with a php extension, and point it at your endpoint. Open it in your browser and it will send the message. Because the message does not originate from eBay, the verification will fail with a 500 error, but if you get to the verification part then everything else should be working.

Endpoint tester

0 Likes 0 ·
BTW, a 444 means the requesting server didn't receive a response. It doesn't mean the message failed to send. It means your server didn't respond before the connection was closed.
0 Likes 0 ·
adr-647048 avatar image
0 Likes"
adr-647048 answered

hi friend , have you solved this problem? i am running to this same proplem

10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.