question

ecoatm avatar image
1 Like"
ecoatm asked

Unable to enable Marketplace Account Deletion after disabling it

I've run into an issue with the Marketplace Account Deletion settings where I now can't do anything at all.

Here is how I seem to have gotten into this:

  1. I entered the information and (after some testing) got the notifications working
  2. I changed some settings while doing further development. Since the Marketplace Account Deletion system isn't active in the sandbox, this was done in production
  3. While doing this, I received an email notification that the endpoint was no longer working
  4. I finished the development on my end and updated the endpoint settings
  5. I noticed that, while I had the endpoint working initially, I received many notifications per day, I was now receiving nothing (except Test Notifications if I requested them)
  6. I attempted to change the settings, even updating the endpoint address on my end and then in the eBay settings, to no avail
  7. As a last resort, I disabled Marketplace Notifications (the "Not Persisting eBay Data" button) to try re-enabling it
  8. After doing this, trying to re-enable the setting gives me first a confirmation dialog, after clicking "Confirm" it gives an error that something went wrong.

I've waited a couple of days and the error is still persisting. I can't re-enable marketplace notifications.


Note: this is still happening. It appears that until eBay fixes this, I will be opted out of Markteplace Notifications forever. I don't really want to pay for premium support just to try to get them to fix the system.

marketplace account deletion notification endpoint
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

ecoatm avatar image
0 Likes"
ecoatm answered

Today I got an email from eBay saying that my endpoint was working again. I checked and it was still set to not persist data, but this time it let me change it to enable it again.

After this was done, I realized I still wasn't seeing any notifications. Digging into it further, I discovered that the test notification sends the signature in the header with a name of "x-ebay-signature" (lowercase) and in the actual notification the name is "X-EBAY-SIGNATURE" (uppercase). Since Salesforce treats these differently, I updated my code to check both and the notifications are now working properly.

10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

jacobn-7583 avatar image
0 Likes"
jacobn-7583 answered

Pleased to see your issue as I think I have the same problem, I am also confused and in need of light on this same issue. Need help.


Myloweslife


10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

zpav89 avatar image
-4 Likes"
zpav89 answered

But if anything the problem has increased in intensity since then. There are many reasons why Facebook might disable your account.


mcdvoice


10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

dlumpp491r avatar image
0 Likes"
dlumpp491r answered

I'm in the same boat. My endpoint got marked down and I corrected the problem same day. Does anyone know how to get it marked as responsive again? I did send a successful test notification but that didn't help.

10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

surgewares avatar image
0 Likes"
surgewares answered

Heh, I went through almost the exact same steps. eBay's system here seems to be a complete mess. I had my endpoint working and validated, but had a small problem where it filled up the db table quicker than I anticipated. That was a simple fix, but now eBay won't validate the endpoint anymore despite the fact that it accepted it before and I've verified a 200 response with the correct json from Postman. As a last ditch effort I also used the "Not Persisting eBay Data" button to see if that would help clear something out so I could start again. Nope, now I can't even enable re-enable that setting without getting an error. Ugggh. Mostly just replying here to tag this post in case anyone finds a workaround.


· 1
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

I was able to re-enable the marketplace settings again, I'm not sure what changed but after I got the email from eBay saying my endpoint was working it let me do that. However, my initial reason to disable it (not getting notifications in spite of endpoint being validated) was different than yours (endpoint not validating).
0 Likes 0 ·
prepaidgibl_0 avatar image
0 Likes"
prepaidgibl_0 answered

Wonderful submit, very informative. I wonder why the opposite experts of this sector don't notice this. You should continue your writing. I am sure, you have a great readers' base already!


Prepaidgiftbalance

10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.