question

richstone avatar image
0 Likes"
richstone asked ·

BUG REPORT: OAuth - Invalid access token immediately after creation

I'm trying to use the Inventory API.

Despite having problems, I've managed to get a User OAuth token, but when I try to run a request, it says:


{
    "errors": [
        {
            "errorId": 1001,
            "domain": "OAuth",
            "category": "REQUEST",
            "message": "Invalid access token",
            "longMessage": "Invalid access token. Check the value of the Authorization HTTP request header."
        }
    ]
}


The weird thing is, immediately after the creation of the token it says that it expires the same minute. E.g. I requested a token today at 9:27:

Captura de pantalla 2020-09-20 a las 9.34.25.png


I tried to request a new token with the same result...

apiuser tokensecurityapikey
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

· Write an Answer
richstone avatar image
0 Likes"
richstone answered ·

despite of the weird expiry date, the token seems to work now (I wrongly used the sandbox token for the production environment)

· Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.