question

mchaban-47 avatar image
0 Likes"
mchaban-47 asked

createOrReplaceInventoryItem sample not working

Hi. I'm trying to call **createOrReplaceInventoryItem** method to eBay sandbox with sample, provided in docs: https://developer.ebay.com/api-docs/sell/inventory/resources/inventory_item/methods/createOrReplaceInventoryItem But response from API shows error: "Invalid value for .". Request: PUT https://api.sandbox.ebay.com/sell/inventory/v1/inventory_item/GP-Cam-01 Request Headers: Content-Language: en-US Authorization: Bearer HERE_IS_MY_TOKEN_THAT_I_REMOVED_FOR_SECURITY_REASONS Content-Type: application/json Accept: */* Host: api.sandbox.ebay.com Accept-Encoding: gzip, deflate, br Connection: keep-alive Content-Length: 1129 Request Body: { "availability": { "shipToLocationAvailability": { "quantity": 50 } }, "condition": "NEW", "product": { "title": "GoPro Hero4 Helmet Cam", "description": "New GoPro Hero4 Helmet Cam. Unopened box.", "aspects": { "Brand": [ "GoPro" ], "Type": [ "Helmet/Action" ], "Storage Type": [ "Removable" ], "Recording Definition": [ "High Definition" ], "Media Format": [ "Flash Drive (SSD)" ], "Optical Zoom": [ "10x" ] }, "brand": "GoPro", "mpn": "CHDHX-401", "imageUrls": [ " http://i.ebayimg.com/images/i/182196556219-0-1/s-l1000.jpg", " http://i.ebayimg.com/images/i/182196556219-0-1/s-l1001.jpg", " http://i.ebayimg.com/images/i/182196556219-0-1/s-l1002.jpg" ] } } Response Headers: Content-Length: 132 Content-Encoding: gzip Date: Thu, 06 Aug 2020 15:50:19 GMT nnCoection: close RlogId: t6pitnmsgwj%28ciuoopu0asu%60pkal%3C%3Dosutowoiudvn.077602%29pqtfwpu%29osu%29fgg%7E-fij-173c4774e0f-0x324b X-EBAY-C-REQUEST-ID: ri=hXYOFp6kZZAV,rci=691f331f3b2a5262 X-EBAY-C-VERSION: 1.0.0 X-EBAY-ESB-UPSTREAM: slrinvapi.vip.sandbox.ebay.com Content-Type: application/json Connection: keep-alive Response Body: { "errors": [ { "errorId": 25709, "domain": "API_INVENTORY", "subdomain": "Selling", "category": "REQUEST", "message": "Invalid value for ." } ] } Please, check the sample, or help me to figure out, if anything wrong on my side. Regards.
createorreplaceinventoryitem
10 |600

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

naizarak2 avatar image
0 Likes"
naizarak2 answered
you're not doing anything wrong, the create item/bulk create item calls have been broken for several days
10 |600

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

sha-765148 avatar image
0 Likes"
sha-765148 answered
@mchaban-47 - were you able to resolve this isue?
10 |600

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

mchaban-47 avatar image
0 Likes"
mchaban-47 answered
@naizarak2, thank you, for your response. @sha-765148, no. The issue still exists.
10 |600

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

sanjiv_developersupport avatar image
0 Likes"
sanjiv_developersupport answered
Hi @sha-765148, Can you please give a retry now and provide us with the rlogid if it still fails with the same error message?
10 |600

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

sha-765148 avatar image
0 Likes"
sha-765148 answered
@sanjiv_developersupport - I don't get why the response time is so slow. It seems like lot of people are having this issue. I gave a retry and got the same error. Here is the RAW response HTTP/1.1 400 Bad Request Content-Length: 132 Content-Encoding: gzip Date: Tue, 11 Aug 2020 12:21:15 GMT nnCoection: close RlogId: t6pitnmsgwj%28ciuoopu0asu%60pkal%3C%3Dosutowoiudvn.077602%29pqtfwpu%29osu%29fgg%7E-fij-173dd77b16c-0xb5c0 X-EBAY-C-REQUEST-ID: ri=QS%2BzCC5GmW5D,rci=2256f69ec0ff7850 X-EBAY-C-VERSION: 1.0.0 X-EBAY-ESB-UPSTREAM: slrinvapi.vip.sandbox.ebay.com Content-Type: application/json Connection: keep-alive
10 |600

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

sha-765148 avatar image
0 Likes"
sha-765148 answered
And the body - { "errors": [ { "errorId": 25709, "domain": "API_INVENTORY", "subdomain": "Selling", "category": "REQUEST", "message": "Invalid value for ." } ] }
10 |600

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

crutchfield_electronics avatar image
0 Likes"
crutchfield_electronics answered
We started having issue with this API call on 8/7, and only get "a system error has occurred". Is there an ETA on when this will be fixed?
10 |600

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

naizarak2 avatar image
0 Likes"
naizarak2 answered
the calls are now working properly for me in production. i was able to publish a new listing from scratch on the US site
10 |600

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

sanjiv_developersupport avatar image
0 Likes"
sanjiv_developersupport answered
@naizarak2, Thanks for the confirmation. @sha-765148, can you please give a try in production also and share your feedback?
10 |600

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

sha-765148 avatar image
0 Likes"
sha-765148 answered
@sanjiv_developersupport - I don't have a production environment yet. I am still in development phase. All my developers are stuck because of this issue. This needs to get resolved ASAP.
10 |600

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.