question

freezedefense avatar image
0 Likes"
freezedefense asked ·

Sandbox and Production: Cannot get user tokens

I am having trouble getting user access tokens. I checked over the documentation, and cannot figure out what I am doing wrong. On the Sandbox, I can get as far as getting the code to mint a user access token. (After logging in as a test user.) But when submitting to the API the information, I get an error saying invalid client credentials. I am properly passing the Basic authorization header with the base64 encoded clientid:secret. For production, I cannot even get to the signin page to login as a user. (Even when clicking to test from the developer portal) It immediately errors out with a JSON response 500 error: The authorization server is currently unable to handle the request. Does anyone have any advice on what to check? I went through the oauth docs again, and I think my coding is correct.
oauthauthentication failedserver error
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

· Write an Answer
freezedefense avatar image
0 Likes"
freezedefense answered ·
The API suddenly started working this afternoon. No changes to code were made, the Sandbox and Production APIs just started working. Wonder if it was because the dev account is new, and maybe it takes time for the system to activate the keys?
· Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.