question

56bits avatar image
0 Likes"
56bits asked ·

GetOrders does not return a ShippedTime key for Orders with more than one Transaction

Hi guys, have been running into trouble recently with the `GetOrders` API call. I'm using the presence of the `ShippedTime` key to filter orders that have already been marked as shipped. This usually works, but the key is never present for orders which have more than one `Transaction` in their `TransactionArray` - even when the order has been marked shipped through My eBay/Selling Manager Pro. I have tried with both compatibility layer 1111 and whatever the default for the python wrapper is (I believe 689) and both show this behaviour. Steps to reproduce: 1. Mark an order with multiple transactions as shipped through My eBay. 2. Note that it now appears under "Paid and Posted" in SM Pro. 3. Through the API, submit a `GetOrders` call. 4. Check the XML response. 5. Note the lack of `ShippedTime` key for the order that had multiple transactions. Do those steps fail for others? Can anyone think of a possible workaround to get the Shipped status without using the `ShippedTime` key from `GetOrders`?
getorder
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

jourbandts avatar image
0 Likes"
jourbandts answered ·
Hi @56bits, You should in fact be seeing the shipped time as you mentioned. The 2 ways to trigger this is either by every item in an order being shipped or the seller marking the order as shipped. Unfortunately without a sample we cannot give a definitive reason as to why you are seeing this issue. Can you please take one of the actions below, 1. Provide us with a sample request and response (you can delete out any private info) 2. You may want to reach out to developer support directly because if this is a bug we will need much more information from you, https://developer.ebay.com/my/support/tickets
· Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

sanjeev_developersupport avatar image
0 Likes"
sanjeev_developersupport answered ·
Hi @56bits, Sorry for the trouble caused to you. we'll need a few more details in order to help you better on this: 1. Sample request and response. 2. How you are making the call (i.e. API explorer, browser, Java, etc) 3. Please confirm you are in the sandbox or production environment. 4. Did this work previously or are you trying to make this API call for the first time?
· Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

56bits avatar image
0 Likes"
56bits answered ·
Bump. Is anyone able to reproduce this error, or think of a workaround? I've had to park the current project I'm working on for this reason.
· Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.