question

ict-direct avatar image
0 Likes"
ict-direct asked ·

Finding API is returning 0 items?

I am running into an issue, I noticed my app was not displaying information regarding the "Finding API" more specifically the "FindCompletedItems" call. I get no errors from eBay, it just returns "0" items. It doesn't happen 100% of the time, but it does happen for about 80% of the requests that I make. I tested it directly in the eBay API explorer, for example. The API explorer's example for "iPhone" only returns "2" items. (That's bonkers! Only 2 iPhones have sold on eBay?) When I type some other popular items like LG G3, LG G3 Phone, iPod Touch, iPod Touch Home Button, etc., I get "0" Items returned. I also found that I get the same results under the "FindItemsByKeyword". I believe the API is broken. Am I missing something? Is there a new API I should be using? I am desperate to get this resolved. Please help if you can.
apiapi-problemapi callfinding apihelpapi-searchhelp requiredcompleted-listingsbrokencompleted items search
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

· Write an Answer
helios825 avatar image
0 Likes"
helios825 answered ·
It sounds like you are using the Sandbox. Be sure you're using Production, whether in the API Explorer, or in your API calls. I've seen findCompletedItems return occasional false empty results sets (in Production), but it's infrequent and I can re-call for proper results.
· Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.