question

estrabd avatar image
0 Likes"
estrabd asked ·

[Bug] Filter SoldItemsOnly for findCompletedItems returning very few of the actual sold items

I am setting the "SoldItemsOnly" filter for calls to "findCompletedItems". I am getting a very small number of results. I know this is incorrect because in my automation, I first make calls to "findCompletedItems" to get all items (sold or unsold); then I make another set of calls to get only sold items so that I can mark what actually sold. For a given date for my category of concern, I might get 2-3,000 completed items. When I set "SoldItemsOnly", I am getting less than 50. I can easily see the number of auction items that have 1 or more bids that are definitely sold, but not returned when setting "SoldItemsOnly". https://developer.ebay.com/devzone/finding/CallRef/types/ItemFilterType.html https://developer.ebay.com/devzone/finding/CallRef/findCompletedItems.html#Samples (see sample call uses this filter) I believe this is a bug. Please advise. Update: I'd like to add that as a work-around I am tempted to store any item with 1 or more bid to be "sold", but I know this is not accurate. I'd like the filter to work as advertised so that I can get accurate information for all listing types.
findcompleteditemsbugbug report
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

· Write an Answer
chris_auctions avatar image
0 Likes"
chris_auctions answered ·
figure this out? having similar problems
· Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.