question

jkrus10414 avatar image
0 Likes"
jkrus10414 asked

Shopping API is Serving the Wrong URL

Hello,

 

I am currently using the FindReviewsAndGuides call within the Shopping API.

 

Within the API response, the "ReviewsAndGuidesURL" returns a rover link. This link  is not sending the visitor to the correct landing page.

 

For example for Product ID: 84898004  the rover link will send the visitor to this page:

 

http://www.ebay.com/ctg/84898004/r.html?_fcls=1

 

This is INCORRECT.  The "ctg" in the above link needs to be something different so that the visiotrs' browser will automatically scroll down on the above landing page and display the reviews for the product. This error occurs on every response for every product ID sent to the API when using the "FindReviewsAndGuides" call.

 

Does anyone know where I can report this to eBay so that it can be fixed?

 

 

Thanks.

 

 

 

 

shopping-apireviewsfindreviewsandguides
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

shulmani_developer.support avatar image
0 Likes"
shulmani_developer.support answered

Hi,

 

Can you please provide me the the request that you sent? Just the request without your AppID.

This will help us re-produce the issue and  look into it.

 

Cheers!

10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

jkrus10414 avatar image
0 Likes"
jkrus10414 answered

Hello,

 

I've replaced our "trackingid" and our "appid" with "xxxxx" in the call that we are using. 

You must use a valid "trackingid" so that the link that is returned from the API is a "rover" link.

 

You can use any valid "ProductID.Value".

 

As described above, the rover link that is returned, from the API, is not sending the visitor to the reviews section of the final landing page at eBay. This problem is ONLY for the U.S.  locale. The other locales seem to be working correctly using the same call. 

 

 

http://open.api.ebay.com/shopping?ProductID.Value=100189824&affiliate.ge...

 

10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

jkrus10414 avatar image
0 Likes"
jkrus10414 answered

 

Here is more clarification:

There is a rover link that is returned from the API within the "ReviewsAndGuidesURL" XML tag. When the vistor follows the rover link he/she is landed on this page: 

 

http://www.ebay.com/ctg/84898004/r.html?_fcls=1

 

The visitor SHOULD land on this page:

 

http://www.ebay.com/rvw/84898004/r.html?_fcls=1

 

Notce the "ctg" should be a "rvw". This error occurs if you enter in ANY valid product ID into this call with a valid partner ID number.

 

When will this be fixed?  This has been an error for about 5 months now.

 

Where can I report this so it can fixed?????

 

Thanks.

 

 

 

10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

InactiveAutoUser avatar image
0 Likes"
InactiveAutoUser answered

 

Hi,

 

When I tried this, i got the below value in the <ReviewsAndGuidesURL> tag

 

http://rover.ebay.com/rover/1/711-53200-19255-0/1?campid=8873550291&cust...

 

This takes me to the http://www.ebay.com/ctg/100189824/r.html?_fcls=1 page.

 

The two URLS that you have mentioned:

http://www.ebay.com/ctg/84898004/r.html?_fcls=1 

and

http://www.ebay.com/rvw/84898004/r.html?_fcls=1

 

Both Point to the same page, the URL http://www.ebay.com/rvw/84898004/r.html?_fcls=1

gets resolved to http://www.ebay.com/ctg/84898004/r.html?_fcls=1 

 

Let me know if I am missing something

10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

InactiveAutoUser avatar image
0 Likes"
InactiveAutoUser answered

 

Hi,

 

if you want to get the issue resolved, you can open a support ticket at :http://developer.ebay.com/support/developersupport/request/ . This is a paid support. But if the issue is because of  a bug at eBay's end, you will not be charged for the ticket.

10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

jkrus10414 avatar image
0 Likes"
jkrus10414 answered

 

That url you provided requires me to purchase hours before proceeding with anything. I have give them $75.00 before proceeding with anything there, so that is not a godd idea.  Do you have a phone number I could call? It would be much easier because nothing is getting resolved or fixed here and its taking to long for anyone to respond.

 

Yes you are missing something. You are supposed to replace the "ctg" with "rvw" in the url after your browser lands on the page. The "rvw" is where the visitor is supposed land, however, the eBay server isn;t sending them there.

 

Here is the issue repeated with more detail:

 

 When using the "ReviewsAndGuidesURL" call and while using the affiliate partner code within the call, the "ReviewsAndGuidesURL" tag returns a rover link. When the browser goes to the rover link, the eBay server redirects the to the incorrect landing page.

 

Here is one example:

 

Using ProductID: 100189824

 

The rover link that is returned within the "ReviewsAndGuidesURL" tag is: 

 

http://rover.ebay.com/rover/1/711-53200-19255-0/1?campid=5337160176&cust...

 

 

If you cut and paste the above URL into the browser you will land on this page:

 

http://www.ebay.com/ctg/100189824/r.html?_fcls=1

 

This is the wrong page!!!  The correct page SHOULD BE:

 

http://www.ebay.com/rvw/100189824/r.html?_fcls=1

 

This error occurs when using any  ProductID when making the call. This error only occurs on the US locale. The other locales (UK, DE, AU, etc...) are working correctly.

 

 

When can this get fixed?  This has been a problem since last October. I am not going to pay $75.00 to submit this at the URL you previously posted.

 

Is there a phone number I can call and talk to someone about this?  This forum is not getting this matter fixed...

 

Thanks.

10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

jkrus10414 avatar image
0 Likes"
jkrus10414 answered

 

Since I wrote the last response, someone has changed the API. Now the link that is returned within the "ReviewsAndGuidesURL" sends the visitor to an error page at eBay.

 

This API is a mess and is poorly managed. 

10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

InactiveAutoUser avatar image
0 Likes"
InactiveAutoUser answered

 

Hi Jkrus,

 

The issue is resolved but the ReviwesAdnGuidesURL returned in the FindReviewsAdnGuides API response is now pointing to the catalog page,

We are still investigating the issue.

 

Cheers!!

10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.