question

zhangliandon_0 avatar image
0 Likes"
zhangliandon_0 asked

Platform Notification not working

I have set up the notification preference through api by SetNotificationPreferences and verified the setting is correct by GetNotificationPreferences. However, I do not receive any notification either http or email. Then I check the usage by GetNotificationsUsage. It all shows 0 usage. Did I set something wrong?
notifications
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

zhangliandon_0 avatar image
0 Likes"
zhangliandon_0 answered
Addtional: I can successfully get notification from sandbox environment. But when I move it to the production, It does not send any notification.
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

frugalgamernet avatar image
0 Likes"
frugalgamernet answered
still not getting anything? considering the lack of response from ebay re their failing system i think we have 3 options 1. setup periodic requests rather than rely on push notifications, ie - give up. 2. hack a solution by parsing PAYPAL emails, ie give up. 3. wait for 6 months and hope that someone at eBay see this and enables notifications on our accounts, ie give up.
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

zhangliandon_0 avatar image
0 Likes"
zhangliandon_0 answered
Finally find a way to get it work by using Auth’nAuth, it is able to work
· 1
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

i am already using auth'n'auth you getting emails as well as hits to your soap url?
0 Likes 0 ·
voolfan avatar image
0 Likes"
voolfan answered
Really glad I'm not the only one having issues with this. Been trying for 2 weeks to get any kind of notification from either environment. GetNotificationPreferences showing that I'm successfully subscribed to the correct notifications, but GetNotificationsUsage showing zero delivered/failed. There must be thousands of integrations that have been written and are receiving notifications successfully, so it makes me think there must be something I've done wrong. If I figure it out I'll post an update. Unfortunately though, as it stands the only option available seems to be to use a Paypal IPN listener and try to determine from that which payments relate to Ebay orders, then use an Ebay API to get details of that order so we can perform stock control - which seems ridiculous.
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

voolfan avatar image
0 Likes"
voolfan answered
As promised, here is an update now that I have notifications working. I have used Ebay's premium support, and gone backwards and forwards with them for the last month. After multiple messages from support trying to help track down the issue, they have replied to me today and said the following: > I have enabled your Sandbox AppID [AppID] which is integrated with OAuth token for SetNotificationPreferences API calls. And now, it has started working. What I have concluded from this is that they went away and 'turned it on', and now it is working as expected. Bizarre, and unfortunately not very helpful for anyone else.
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

stei_155 avatar image
0 Likes"
stei_155 answered
Did someone get this to work? I swear I have tried everything.
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

voolfan avatar image
0 Likes"
voolfan answered
Hi Stei_155, For me at least, this turned out to be that I was using OAuth instead of Auth'n'Auth. If you are using OAuth authentication, somebody at Ebay has to enable your App for platform notifications. Unfortunately, the only way that I found to speak to someone at Ebay and get platform notifications enabled for OAuth, was to pay for the premium support and put in a support ticket. Note: the support tickets I put through did not use up any of the premium support time that I purchased, but this is what I needed to do to get my foot in the door and get a response.
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

stei_155 avatar image
0 Likes"
stei_155 answered
Hi voolfan, I will try this asap. Thanks!
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

llanexchange avatar image
0 Likes"
llanexchange answered

@zhangliandon_0 did you ever get it working. I'm having the same issue where it works in sandbox but not production

10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.