question

jameche-8 avatar image
0 Likes"
jameche-8 asked

Product not found; SKU(s) not in the system

My sandbox app id: **AllInter-test1-SBX-85d7504c4-0e59588e** I created a bunch of items and was about to publish them in sandbox but got error: **Product not found** I looked through the forum and found some said this may be caused by products on multiple sites. So I thought I'd clear the items and do them again. I started using ** getInventoryItems** to get 204 items. Then I tried to delete these items by using **deleteInventoryItem** but got errors: **25701 One or more of the supplied SKU(s) could not be found in the system.** Who has any ideas of what's happening?
sku not founddeleteinventoryitemproduct not foundpublish itemsinventury api
10 |600

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

zhuowei.developersupport@ebay.com avatar image
0 Likes"
zhuowei.developersupport@ebay.com answered
Hi jameche-8, If you are still facing the error, Can you provide the rlogid http response header for the same? Best Regards,
10 |600

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

jameche-8 avatar image
0 Likes"
jameche-8 answered
I'm sure I used user token and correct scope and tested again using below steps: 1. **createOrReplaceInventoryItem** an inventory item with sku **100200** and got response code **204**. 2. **getInventoryItem** the inventory item with sku **100200** and got the item object. 3. **getOffers** found the offer **5382809010** related to sku **100200**. 4. **updateOffer** the offer **5382809010** with new price and quantity and got response code 200. 5. **bulkUpdatePriceQuantity** the item with sku **100200** with new price and quantity and got response code 200. 6. **getInventoryItem** the item with sku **100200** and got the item. 7. **publishOffer** the offer **5382809010** but got response code 400. The error code is: **25604**. Error message is "Input error. Seller Inventory Service can not publish the data. Product not found. Please try again or contact customer support.."
10 |600

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

jameche-8 avatar image
0 Likes"
jameche-8 answered
Not having that error anymore
10 |600

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.