question

albla-29 avatar image
0 Likes"
albla-29 asked ·

Getting error API application 0 invalid

HI, I am getting the API application 0 invalid error, which suppose to mean that I have the platform all wrong. BUT, I created sandbox keys and I am using sandbox addresses.Can somebody help please. Thank you
ebay api .net
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

6-implant avatar image
0 Likes"
6-implant answered ·
having the same problem, all of the credentials are valids Token, Cert, Dev ID and App Id still can't figure out what is the problem
· Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

sree_developersupport avatar image
0 Likes"
sree_developersupport answered ·
Hi @bloomingartificial, Can you please check if you are using Token or ApplicationName\Cert Name and DevName for authentication ? Can you please verify if the Token is valid? Can you please verify if the AppName you are providing is valid? Best Regards, eBay Developer Support
· Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

bloomingartificial avatar image
0 Likes"
bloomingartificial answered ·
Hi There, I am also getting the same error in the production environment; this is very annoying when it's working on my local server and with same details it giving me the following error when i run my application on our dedicated server it giving this error. ns1:Client Application name invalid. http://www.ebay.com/ws/websvc/eBayAPI 127 Error API application "{0}" invalid. Can anyone help please? Thanks, BA
· Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

albla-29 avatar image
0 Likes"
albla-29 answered ·
Hi I am really sorry, I honestly thought I answer my question, because I found the problem. The problem was that I had no token. I thought that you can add an item with my account because I am only testing and I used the same user name and pass for everything including the test user. SORRY. Now I stuck with adding a picture to my item, I keep on getting 10007 as return every time I add a good picture for my item. I tried small and large images. My user id is testuser_smobilesoft. Any help will be appreciated.
· Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

sree_developersupport avatar image
0 Likes"
sree_developersupport answered ·
Hi @albla-29, Thanks for your post. Can you please share your sandbox.ebay.com user ID ? It might be because your account might not have been set with proper account type. Also, if you can send us the request and response files, it will be helpful for us to triage. PS: Can you please remove the Auth Token and send us the request file. Best Regards, eBay Developer Support
· Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.