question

$$anonymous$$ avatar image
0 Likes"
$$anonymous$$ Suspended asked

The underlying connection was closed

Hi, since 6 days ago i've having some problems calling the API's method "CompleteSale" via .NET SDK (v967). When the ERP try to send some updated informations about the order, it receive this Exception: "the underlying connection was closed an unexpected error occurred on a send", so i've not a response from the API. There are more than one strange things: 1. there are some batch in background, using the same .dll, and they work fine; 2. rebooting the server the first call to "CompleteSale" works fine; 3. after registering again the .dll via the "regsrv" command, it worked fine for one day; 4. all operators that uses the ERP are connected to the server via remote desktop and all of they notice the problem. Instead, if i connect from the my company's office, all works fine. The ERP is developed in progress (4GL), so i can't fix with setting "KeetAlive" to "false" or making other interventions on .net side. Thanks in advance and sorry for my bad english. Daniele
.net sdkcompletesalecompletesale-apiweb apiconnection problemthe underlying connection was closed
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

$$anonymous$$ avatar image
0 Likes"
$$anonymous$$ Suspended answered
I've checked the Security Protocols on the api's servers discovering that the "SSL3" is not longer supported whereas the default value for the ServicePointManager.SecurityProtocol in .NET 2.0 is SSL3. I've solved the problem by adding this hotfix at the "eBayXmlAPIInterfaceService" class in the SDK's source code: //768 = Tsl1.1, 3070 = Tsl1.2 ServicePointManager.SecurityProtocol = (SecurityProtocolType)3072 | (SecurityProtocolType)768; HttpWebRequest http = (HttpWebRequest) WebRequest.Create(this.Url); http.Method = "POST"; http.ContentType = "text/xml"; http.ContentLength = data.Length; http.KeepAlive = false; Probably Microsoft as released an hotfix to correct this problem but the server wesn't updated since 2015.
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

sree_developersupport avatar image
1 Like"
sree_developersupport answered
Hi, Thanks for your forum post. Can you please send us the request and response file for any of the failures that you are seeing? This will help us triage the situation much better. Also, please specify your SellerID. Please do comment out the token in the request file. Best Regards, eBay Developer Support
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

$$anonymous$$ avatar image
0 Likes"
$$anonymous$$ Suspended answered
Hi,
this is the seller id: **ricambi_smc**.
However i can't provide you the request or the response, for this call, because the first one wasn't sended, so i can't intercept those.
Because of that i suppose there is nothing wrong with the api communication, moreover if i restart the server the first call is fine. Could be a problem of the .dll version?
The sync has stopped working on 30/10, do you know if was done some changes on this date?
Thanks
Daniele
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.