question

phiporte_7 avatar image
0 Likes"
phiporte_7 asked

Notifications - (http) DELIVERY_UNFINISHED:The message did not deliver in 30000ms

I've tried getting notifications using http and https ([which I've documented here][1]). Using http I receive a different message; The message did not deliver in 30000ms. I have an application for testing which post to the web service and it works over http and https but no success with eBay's sandbox. I'm getting the idea that this just doesn't work (or at least it doesn't for the sandbox) and that I should use the API instead and poll the ebay system. [1]: https://forums.developer.ebay.com/questions/23186/notification-error-sslengine-closed-already.html
notificationssandbox not working
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

sree_developersupport avatar image
0 Likes"
sree_developersupport answered
Hi, Thanks for your post. We support both HTTPS AND HTTP. Can you please let us know if you have SNI Enabled for HTTPS. I see that you are using ""https://p***.net:8080/ebay***.asmx"". ? Best Regards, eBay Developer Support
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

sree_developersupport avatar image
0 Likes"
sree_developersupport answered
Hi @phiporte_7, Can you please check the below link: https://www.ssllabs.com/ssltest/analyze.html?d=ppgainc.net It looks like there is a certification mismatch. Can you please check and update the same? Best Regards, eBay Developer Support
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

phiporte_7 avatar image
0 Likes"
phiporte_7 answered
Hello, Thanks for the reply. I set the notification preferences to use rapidsprout.com:8080 several days ago as I removed ppgainc.net from the notification preferences. I removed it to try some different settings. Apparently something has not gotten updated. [You can check out the certificate here.][1] I've used MS Network Monitor and get the client/server handshake then a few ack and finally an alert. The alert is Certificate Unknow (46). This makes sense since it's referencing ppgainc.net and not rapidsprout.com. Something didn't get updated. I've since set it again. I'll try it later. [1]: https://www.ssllabs.com/ssltest/analyze.html?d=rapidsprout.com
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

phiporte_7 avatar image
0 Likes"
phiporte_7 answered
Still getting; DELIVERY_ASYNC_HTTP_EXCEPTION:NewHttpsEventSender Async: Exception message is SSLEngine closed already from GetNotificationUsage when specifying the ItemID. From the server side after the handshake I get an alert message; Certificate Unknow (46). [Click here to verify the certificate with ssllabs.com.][1] The browser doesn't have issues with the site; [ https://rapidsprout.com:8080/ebaynotification.asmx][2] I've created a C# Windows test project to post a soap payload and it works without any issues. What else can be done to debug this? [1]: https://www.ssllabs.com/ssltest/analyze.html?d=rapidsprout.com [2]: https://rapidsprout.com:8080/ebaynotification.asmx
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.