question

jason_damisch avatar image
0 Likes"
jason_damisch asked

LMS Large Merchant Services - Unable to use Service

I was trying to work with LMS a few years ago, and was successful in connecting with the server and in using the Bulk Data Exchange API using such calls as createUploadJob and getJobs. Today I attempted to use the exact same program I wrote to try to talk to that API. Now I am unable to use that API. I was wondering if something has changed. Perhaps I no longer have permission to try to use that API? Or, maybe there is something with my APP keys or with my Auth Token which won't let me use them? Do I need to generate new App Keys? I'm just guessing. I'd like to move ahead with my programming project and this service. Any clues would be appreciated. One thing is that in the API explorer the Bulk API does not show up in the drop down Select API for anything having to do with Bulk. That is for any Keyset that I have. Thanks
lmslarge merchant services
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

jason_damisch avatar image
0 Likes"
jason_damisch answered
I'll try to fill in details as I can think of them. I can successfully use AddFixedPriceItem EndFixedPriceItem RelistFixedPriceItem ReviseFixedPriceItem So I know that my code is otherwise working. I am in the Sandbox.
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

jason_damisch avatar image
0 Likes"
jason_damisch answered
I was a few years ago successful in create a test file of about 300 items and then getting them to go up to the Sandbox using the LMS. So, I know that my setup was working before. Now it is not. That is to clarify.
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

jason_damisch avatar image
0 Likes"
jason_damisch answered
I have to admit that I found my own answer. I was munching my eBay Auth Token in the call headers. I was not putting the full Auth Token in. In fact I was cutting it off. so instead of putting in 872 bytes for it I put in under a hundred bytes. I successfully made a call to getJobs I remember now inserting a bug into my code when I copied it to a new directory and then edited it a little bit. My bad. It's strange though because the second to the last thing I tried was to get the OAuth token for my App key and then I tried that. When I tried that I'm pretty sure that I didn't munch it. I still was not able to get a good boogie with the server using it. I suppose that I need to learn more about the new auth system to be able to use it. Anyway, onward trudge.
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

ham_5672 avatar image
0 Likes"
ham_5672 answered
Hi hason_damisch, I was stuck to use OAuth (new security) in LMS. Could you please share a sample code to pass the OAuth when calling this DLL? Le
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.