question

mholbrgr avatar image
0 Likes"
mholbrgr asked ·

Completed orders not found in GetOrders call until many hours later

After the processing incoming orders through the API and then shipping them, my application attempts to upload the tracking number. When I then perform a GetOrders call with just the NumberOfDays parameter set, it takes almost a full day before some orders are able to be found using this API call. This is creating a delay in my tracking# uploads for some orders. This just started happening in the past couple days. What gives? Are the API servers having another bad day? I currently have 6 orders from today that have been completed and shipped, that I just can't seem to find using a general GetOrders call at all?? But then they will show up in there later and upload eventually, same as yesterday.
getordersnot working
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

· Write an Answer
mholbrgr avatar image
0 Likes"
mholbrgr answered ·
I figured it out, my fault of course. We are getting in so many orders now, I forgot to check the pagination. Silly me!
· Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.