question

harut1984 avatar image
0 Likes"
harut1984 asked

WRONG (No Image) item image URL in the response.

Hey guys, I get a quite strange problem related to item image. I am trying to find items by category, and successfully getting the result in the xml format. BUT for some items the **"galleryURL" (item picture url)** redirects to **'No Image'**, but actually item has an image in the ebay (I checked that by opening its url in ebay). So what is this, a **bug in the API**? Here is the rest service url I used (please check and you will see what I mean): http://svcs.ebay.com/services/search/FindingService/v1?OPERATION-NAME=findItemsByCategory&SERVICE-VERSION=1.0.0&SECURITY-APPNAME=XXX&RESPONSE-DATA-FORMAT=XML&paginationInput.pageNumber=1&paginationInput.entriesPerPage=2&outputSelector=GalleryInfo&REST-PAYLOAD&categoryId=97042 This actually returns 2 items, and the picture url of the first item opens a **"No Image" picture**, here is it: http://thumbs1.ebaystatic.com/pict/04040_0.jpg But actually an item has images in the ebay, you can see it by following url: http://www.ebay.com/itm/RDX-Leather-Gel-Tech-Training-MMA-UFC-Grappling-Gloves-Fight-Sparring-Punch-Bag-/281799902653?var=0 And also one more strange thing: both items in the returned xml response **refer to the same item in the ebay** - so they both have the same itemId=281799902653. When I open ebay urls for both of them - the second item openes the same page as item1, but the "Color" is selected as "Black" :) So I am kindly asking you to help me in this, it is **Very Urgent**. Is this an API issue? And do you have any approach on this (the main problem that I am trying to find a solution, is that galleryUrl of the item is a 'No Image' icon - so I have very bad looking view in my web site)? Thanks in advance! Harut
finding-apiproblemimage urls
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

harut1984 avatar image
0 Likes"
harut1984 answered
Hey, nobody knows why this happens? Why we get images with **wrong image urls**? Please feedback, this is very urgent...
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

helios825 avatar image
1 Like"
helios825 answered
Firstly, set your Service Version to something current, like 1.12.0 . It shouldn't matter, but sometimes an earlier version, as you did, creates minor quirks/bugs. Also, know that sometimes an item will be listed without any gallery URL, but with images/pictures as part of the listing. Maybe this is what's happening. As for multiple instances of the item#, I think that can happen with multi-variation items. Here's the eBay website search URL for this item: www.ebay.com/sch/i.html?_nkw=281799902653 Notice 2 items appear in the eBay website results (at least for me). You might be able to collapse multiple item#s using the filter 'HideDuplicateItems': http://developer.ebay.com/DevZone/finding/CallRef/types/ItemFilterType.html You might also considering building your own gallery URL with a hack: http://thumbs1.ebaystatic.com/pict/12345678904040_1.jpg thumbs1 (1 is a random digit) ; 1234567890 is the item# ; 4040 means 140x140 ; "_1" could be "_2" or other random#
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

harut1984 avatar image
0 Likes"
harut1984 answered
THANK YOU SO MUCH! 'HideDuplicateItems' solves everything!!! Thanks again!
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.