question

InactiveAutoUser avatar image
0 Likes"
InactiveAutoUser asked ·

Merchant Data API - SoldReport - Multiple Line Items not combining

I have a Large Merchant Service (LMS) running and I'm calling the SoldReport. When grabbing the data the orders that have multiple line items are coming in as seperate items/transactions as well as a combined order coming in for all of them. Here's what I have, please let me know if it doesn't make any sense.

  •  
  • Multiple Item Order comes through with an OrderID similar to 116356933013
  • The Item Order has multiple OrderLineItemIDs
  • (This is perfect....but then)
  • A day or two later the individual OrderLineItemIDs are now included in the report with CheckoutStatus = Complete
    • They have a different OrderID, but the same OrderLineItemID as the other
    • They Only have one OrderLineItemID per OrderID

What gets me about the whole thing is that the LMS SoldReport states:

 

Lists all items that have been sold by this seller. If a buyer purchased multiple items from a single listing, the sale will result in a single Order ID for the total purchase with a separate Line Item ID for each of the purchased items. The SoldReport request returns the data for all of your new orders (newly-sold items) with Order ID and Order Line Item ID. The Sold Report includes all transactions for the past 30 days (from the transaction creation date). 

 

 

 

So why are the individual line items coming in as separate orders after the fact?

soldreportlarge-merchant-servicesmerchant-data
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

· Write an Answer
jourbandts avatar image
0 Likes"
jourbandts answered ·

Hi,

 

You seem to be encountering a bug.  As you read, those orders should have been combined into 1 order.  So the fact you are seeing them as a combined order and separately is not right.  Unfortunately the forums are not the best place to work on this and I will also need much more information.  i suggest opening a support ticket, http://developer.ebay.com/support/developersupport/.  If this is indeed determined to be a bug there will be no charge.

· 1 · Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

I think that it's already been fixed. I didn't open a support ticket, but the issue has stopped. I'm no longer seeing it in the report...Thank you if you were the one who posted it as an issue.

 

 

0 Likes 0 · ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.