question

asutr01 avatar image
0 Likes"
asutr01 asked ·

Auth token is invalid?

I am getting this error randomly, System.Web.Services.Protocols.SoapException: Auth token is invalid. I checked my token and it is active and it was working fine until today. Expiry date is 03/28/2017. Anyone else having the similar issue. I trying to figure out if it is my application or there are some issues on ebay's end. I am making GetItem call continuously for about 1000 item ID's and sometime I get the error in the beginning and sometimes in the middle. So, I think it is random and seems like it is a problem from ebay's end.
trading apigetitemuser tokeninvalid
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

· Write an Answer
helios825 avatar image
0 Likes"
helios825 answered ·
Yes, I'm seeing very similar behavior. It's Trading API error code 931 - "Auth token is invalid." It's happening for me a very small percentage of the time; most of the time my calls go through OK. I assume it's a random problem on eBay's end. This started for me on Mon-02-Nov. (Maybe we should be posting this thread [here instead][1] for wider exposure?) [1]: https://forums.developer.ebay.com/spaces/15/ebay-apis-getting-tokens-notifications-alerts-mess.html
· 1 · Share
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

For about last 1-2 hour I haven't had any issues. It probably seems like a small glitch on ebay's end. They might be updating something I guess... Thanks for your response.
0 Likes 0 · ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.