question

pmcnary3vc5 avatar image
0 Likes"
pmcnary3vc5 asked ·

Sun JDK 1.5 - Problem on which SDK download to use

The docs say that Java 1.5 and later versions of 1.6 are needed for the Trading API Java SDK.

I downloaded eBaySDKJava771Full.zip

I did not see different download packages for 1.5 or 1.6

 

I get version error 50.0 49.0 needed.

Java SDK 1.6 is not available for my platform at this time.

I can only use Java 1.5

 

Where do I download the eBay SDK Trading API that is compatible with Java 1.5?

 

Thank you

Java
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

· Write an Answer
zhuowei.developersupport@ebay.com avatar image
0 Likes"
zhuowei.developersupport@ebay.com answered ·

Hi pmcnary3vc5,

 

    Please follow the steps below to workaround the error like 'class file has wrong version 50.0 ...' encountered:

  1. go to the $JSDK/build folder, set the JAVA_HOME environment variable in the setenv.bat  file to the JDK of interest and execute the batch

  2. run the ' ant build'  command to re-build the downloaded eBay Java SDK

     - The 'ant build' command compiles and builds all jars files that are compatible with the JDK version specified in the setenv.bat file.

 

   Also, you might want to check the $JSDK/docs/readme.htm file and make sure to include all required additional jar files if any.

 

Best Regards,

 

 

 

 

10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.