question

big-bad-burrow avatar image
0 Likes"
big-bad-burrow asked

GetOrders not supporting all extended ASCII characters

I'm making a call to GetOrders and set all character encoding to UTF-8 but I still get invalid characters in the response, e.g. Andaluc?a instead of Andalucía. Does anyone else have this problem? I have also tried to debug by setting my PHP page to use ISO-8859-1 but I have the same result. header("Content-Type: text/html; charset=iso-8859-1");
getorders-ebay-apiutf-8utf8
10 |600

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

vijayta.developersupport avatar image
0 Likes"
vijayta.developersupport answered
Hi Can you please share an order-id? Thanks
10 |600

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

big-bad-burrow avatar image
0 Likes"
big-bad-burrow answered
Hi @vijayta.developersupport The transactionid: 1212958277019 I have just discovered when viewing the order details and on 'print postage label' it also has a ? in place of the í so it seems perhaps the character wasn't captured correctly when the user input their address details into eBay. So actually I think GetOrders is working okay, but somewhere it's possible to enter address details and the characters are not encoded correctly as UTF-8. Thanks, BBB
10 |600

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.