question

dstudeba avatar image
0 Likes"
dstudeba asked

Notification not received and getOrders call doesn't show sold item

I built a program that removes sold item from my client's webstore when they are sold on eBay. It listens for the ItemSold notification and then uses the ItemID to find the item in my database. Recently the program wasn't notified when a few items sold. Since eBay recommends a periodic check for sold items because notifications aren't guaranteed, this wasn't surprising. I figured I would call GetOrders periodically to make sure I had all the items that had been sold. However when I made the GetOrders API call the missing items didn't show up in that result either. I looked at the items and I can't figure out why I wouldn't get a notification or be able to find them in GetOrders. My client got notified by email about the sale, and the items show up as sold on eBay's website. Thanks in advance for any help. Here are the item numbers for the two most recent problems: 321658335459, 311285942789
apigetordersnotificationsnotifications-itemsold
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

vijayta.developersupport avatar image
0 Likes"
vijayta.developersupport answered
Hi @ dstudeba Can you give me your developer account login-id ? I checked and the ItemSold notification was delivered for both these items. I need to check if it was delivered to your app or not, so please provide your developer account login-id. Can you share the GetOrders request that you executed 'Without' Authtoken ? I need to see if you are using the ModTime filters or CreateTime. In case you have the XML response too, I'd like to create a ticket on your behalf and investigate the issue. Thanks
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

dstudeba avatar image
0 Likes"
dstudeba answered
Thanks for your response! My developer name is : dstudeba The only filter I used was #deleted# 5 ​ The result is too long to post, but now the number is showing up, however I am wondering if this is due to shipping information being added?
10 |600 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.